Nox App Player questions & answers

Emulates an Android operating system on the user's PC
Question by Guest
March 7, 2018

Whenever I post or upload image for Instagram or Facebook, the whole screen goes black.

Answer by Robert Polubinski

This is a problem related to your graphics card, especially if you're using an integrated one. According to a blog post on the developer's website, these graphical cards are not supported or partially supported, therefore if you have one that matches the ones below, update your drivers or install Nox on a computer with a dedicated graphic card:

  • Unsupported:

    Intel G33/G31 Chipset Family
    Mobile Intel(R) 4 Series Express Chipset Family

  • Partially supported:

    Intel HD Graphics 4000+(Intel Haswell HD Graphics – GT2)
    Intel HD Graphics 5000+(Intel Haswell HD Graphics – GT3)

Question by Guest
March 1, 2017

Can I use Nox App Player 2.5 on Intel(R) 82945G Express Chipset Family graphic card? Because latest version of Nox App is not suitable for this graphic card.

Answer by Alex Urbach

Nox App officially supports AMD and NVidia cards that are powerful enough to run everything at maximum. Typically, you should have the possibility to install the application, but a message will appear saying that your GPU is too slow to run everything properly.

If you can't use Nox, then download Memu which is the same thing and compatible with other GPUs.

Question by Billie
December 22, 2016

The game downloads and starts up but the screen is all black with exception of the instruction bubbles! I have removed and re-installed the game numerous times but the same thing happens, My other EA game Simcity Build-It does not have this problem.

Answer by Alex Urbach

You are trying to play a game on an unsupported environment. It doesn't matter if it's Box, Bluestacks or Memu, because apps are configured to run on a certain type of hardware and it's known that not all apps are working in these emulators. Unfortunately, the only thing you can do is to try other emulator (Memu or Bluestacks) or report this to the developers.

There is also the possibility that your computer is not powerful enough when it comes to the graphical settings.

Try Memu using the following link:

Question by pran jal
March 23, 2016

Clash of Clans does not run, showing 'Your device is not compatible'. What do I do?

Answer by Robert Polubinski

Indeed, the game is not available to run in Nox. I downloaded and installed the application, attached a Google Account then tried to install Clash of Clans, but the game can't be found. Initially, I though it's a country restriction policy in effect and used my phone to locate the game and it's there which means Nox is not compatible with the game and that's why is now shown in results.

Contact the developers using the following mail to report this issue:

Question by Ganesh
December 18, 2015
Answer by Sean Hill

There is no official system requirements list, but I can post my details, and then you can get an overview. I have installed the application, and it works very fast, even if my computer is somehow slow compared to others:

  • Windows 8.1 Pro X64
  • 4 GB RAM DDR3 @ 1333 MHZ
  • 250 GB Sata 2 HDD
  • GA-G41MT-S2PT motherboard
  • Intel DUAL-CORE CPU E5700 @ 3.0 GHz

Later Edit: After some extensive searching I have found the system requirements placed deep in the FAQ file.

Here they are:

Click to viewenter image description here

Question by Guest
May 1, 2016

I have fiber optic cable and Internet service that allows me to watch cable on my Android devices. I installed the Nox app emulator on my laptop. Whenever I run the TV app in Nox, it loads OK and I can choose a program or movie easily. The problem is that the screen the picture shows on is very very small (as small as watching on my phone). Whenever I try to go fullscreen the app closes. How can I go to a bigger screen? Can anyone help me fix this problem?

Answer by Alex Urbach

This is a compatibility issue between the application you use and the Nox client. Unfortunately, there is nothing to do except forwarding this to the official Nox developers. Or you can contact the developers of the TV application. As far as I know, NOX Player doesn't have a compatibility viewing mode or a tweak to increase compatibility for apps.

Use the following email to contact them:

Question by Imam Zarkasyi
April 20, 2016

Is there any solution related to fixing of NOx to be able to play the game maker named Netmarble Evil Bane? Nox application is very easy to use, is not as complicated as BlueStacks. Is there any way to keep the game Evil Bane able to walk normally in Nox emulator?

Answer by Robert Polubinski

If the game is not compatible with Nox, then there is nothing you can do about it. Nox works as an entity that can't be modified externally. Instead, you can report this issue to the developers, and they would check it by themselves and release a patch if necessary.

Use the following contact info to report this issue to the developers. They're very responsive.

Tel: +86 (10) 8282 6108

Answer by Guest

This is a known bug and we are trying to fix it in upcoming versions. Kindly stay tuned for our updates.

Question by Guzz
October 27, 2016

This happened when I'd change resolution in startup setting. I tried to restart NOX, reboot windows, reinstall Nox, but it still happens.

I want to set resolution to 800x520 to play games.

Answer by Alex Urbach

The image you have posted doesn't appear to load even after I've visited the official website. However, if Nox is having issues running properly, then I recommend LeapDroid. Leapdroid is practically the same thing as Nox is, only that it's way faster and provides compatibility with a lot of applications.

I am using it on a daily basis and I've never encountered any problems or issues:

Question by someone
October 8, 2016

Each time I try to download any game, a message pops up saying "Verify your account", and it won't let me install the game.


Stephen Prastman
Answer by Stephen Prastman

I've used Nox App Player many times and the only error message that I've encountered was the one where I had to sign into an account to download an application, even if I already was logged on. I suggest logging on Gmail one time on the browser installed on your PC, then switch back to Nox App and remove the account from Settings > Accounts > Your Account > Remove account.

Reboot your PC and add the account again and it should work properly this time.

See more questions & answers

Ask a question about Nox App Player

Alternative downloads

Realtek High Definition Audio

Provides listening capabilities for DTS, Dolby and Surround.

BlueStacks App Player

Download, install, and run Android applications and games on a Windows PC.

EPSON Copy Utility

Use EPSON printer and scanner together like a copy machine.